Benutzer-Werkzeuge

Webseiten-Werkzeuge


wizard

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
wizard [2020/01/15 08:52]
akuhtz [Download]
wizard [2020/07/26 15:08] (aktuell)
akuhtz [CV-Werte anpassen]
Zeile 27: Zeile 27:
 **Aktuelle Release-Version:​**  ​ **Aktuelle Release-Version:​**  ​
  
-Die aktuelle Version ist der **Wizard-1.12.4** vom 21.12.2019.+Die aktuelle Version ist der **Wizard-1.12.9** vom 26.05.2020.
  
-Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12.4.jar+Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12.9.jar
  
 <WRAP center round info 80%> <WRAP center round info 80%>
Zeile 36: Zeile 36:
 Alle Treiber die zur Auswahl stehen werden komplett mitgeliefert,​ d.h. es muss keine separate Installation erfolgen. ​ Alle Treiber die zur Auswahl stehen werden komplett mitgeliefert,​ d.h. es muss keine separate Installation erfolgen. ​
  
-Unter Windows 10 64-bit muss eine 64-bit JVM installiert und verwendet werden. ​+Unter **Windows 10 64-bit muss eine 64-bit JVM installiert** und verwendet werden. ​ 
 + 
 +:!: Falls keine COM-Ports angezeigt werden oder das Fenster mit dem COM-Port nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ installiert werden (Google nach: "​vcredist_x64.exe 2013" oder https://​support.microsoft.com/​de-de/​help/​4032938/​update-for-visual-c-2013-redistributable-package). 
 + 
 +Die **deutsche Version für Windows 10 64-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x64-deu-2013.exe|auch von hier]] heruntergeladen werden.  
 + 
 +Die **deutsche Version für Windows 10 32-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x86-deu-2013.exe|auch von hier]] heruntergeladen werden. 
  
 Siehe auch [[wizard#​usb_hot-plug|USB hotplug]]. Siehe auch [[wizard#​usb_hot-plug|USB hotplug]].
Zeile 67: Zeile 74:
 ** Download Entwicklungsstand ** ** Download Entwicklungsstand **
  
-Der aktuelle Entwicklungsstand (Update: ​12.01.2019, Build 3877, master) vom //​​BiDiB-Wizard-1.12//​​ kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12-20200112.083720-207.jar]]+Der aktuelle Entwicklungsstand (Update: ​11.06.2020, Build 4106, master) vom //​​BiDiB-Wizard-1.12//​​ kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12-20200611.164100-454.jar]]
  
   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.
Zeile 73: Zeile 80:
  
 ---- ----
- 
 ===== Installation ===== ===== Installation =====
 Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //Java 8-Runtime// (oder neuer) installiert ist.  Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //Java 8-Runtime// (oder neuer) installiert ist. 
Zeile 92: Zeile 98:
 Bevor erstmalig eine Verbindung zum Master erstellt werden kann, muss der verwendete Port über **Bearbeiten > Einstellungen** ausgewählt werden (USB-Verbindung zum GBMboost muss eingesteckt sein). Anschließend kann die Verbindung über **Datei > Verbinden** oder über den Connect-Button hergestellt werden. Bevor erstmalig eine Verbindung zum Master erstellt werden kann, muss der verwendete Port über **Bearbeiten > Einstellungen** ausgewählt werden (USB-Verbindung zum GBMboost muss eingesteckt sein). Anschließend kann die Verbindung über **Datei > Verbinden** oder über den Connect-Button hergestellt werden.
 Sobald die Verbindung zum Master steht, werden alle Knoten gelesen und in einer Baumstruktur dargestellt. Sobald die Verbindung zum Master steht, werden alle Knoten gelesen und in einer Baumstruktur dargestellt.
 +
 +==== Sprache ändern ====
 +
 +Die Sprache des Wizard kann wie folgt geändert werden:
 +  * Unter Windows: Im Installations-Verzeichnis vom Wizard gibt es die Datei BiDiB-Wizard.l4j.ini. ​
 +  * Unter Linux: Es gibt ein bash-Script welches den Wizard startet.
 +\\  ​
 +Der folgende Parameter bestimmt die Sprache:
 +''​
 +-Duser.language=de
 +''​
 +
 +
 +Wenn man für ''​-Duser.language=en''​ angibt wird der Wizard in Englisch gestartet.
 +
  
 ==== Installation auf Raspi 3 ==== ==== Installation auf Raspi 3 ====
Zeile 127: Zeile 148:
   * Unterstützung für ReadyLine-Baugruppen   * Unterstützung für ReadyLine-Baugruppen
   * Neues Dateiformat für Import/​Export der Knoten   * Neues Dateiformat für Import/​Export der Knoten
 +  * Korrektur: Fahren mit 28 Fahrstufen (1.12.7)
  
 ==== Version 1.11 ==== ==== Version 1.11 ====
Zeile 277: Zeile 299:
  
 :!: Falls das Fenster nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ (Google nach: "​vcredist_x64.exe 2013" oder https://​support.microsoft.com/​de-de/​help/​4032938/​update-for-visual-c-2013-redistributable-package,​ Achtung: Für Windows passende 64-bit oder 32-bit Version downloaden) installiert werden. :!: Falls das Fenster nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ (Google nach: "​vcredist_x64.exe 2013" oder https://​support.microsoft.com/​de-de/​help/​4032938/​update-for-visual-c-2013-redistributable-package,​ Achtung: Für Windows passende 64-bit oder 32-bit Version downloaden) installiert werden.
 +
 +Die **deutsche Version für Windows 10 64-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x64-deu-2013.exe|auch von hier]] heruntergeladen werden. ​
 +
 +Die **deutsche Version für Windows 10 32-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x86-deu-2013.exe|auch von hier]] heruntergeladen werden.
  
 ---- ----
Zeile 692: Zeile 718:
 Hinweis: In der Abbildung sind in der Spalte Wert nur Fragezeichen drin weil die Abbildung im Demo-Modus erstellt wurde. Nach dem Laden der CV stehen dort die richtigen Werte drin. Hinweis: In der Abbildung sind in der Spalte Wert nur Fragezeichen drin weil die Abbildung im Demo-Modus erstellt wurde. Nach dem Laden der CV stehen dort die richtigen Werte drin.
  
-{{:wizard:wizard-change-servo-cv.png|}}+{{:​wizard:​change-node-cv-values.png|}}
  
-Beim Wizard-1.8 und neuer sind die Buttons zum Lesen und Schreiben der CV-Werte vom Knoten in die Toolbar ​gewandert.+Zuerst müssen die aktuellen CV-Werte über die Buttons zum Lesen und Schreiben der CV-Werte vom Knoten in der Toolbar ​geladen werden.
  
 {{ :​wizard:​wizard-1.9.cv-schreiben.png |}} {{ :​wizard:​wizard-1.9.cv-schreiben.png |}}
Zeile 703: Zeile 729:
  
 Um CV-Werte anzupassen sind folgende Schritte notwendig: Um CV-Werte anzupassen sind folgende Schritte notwendig:
 +  * Aktuelle CVs über den Button in der Toolbar vom Knoten laden.
   * CV auswählen   * CV auswählen
   * CV-Wert anpassen   * CV-Wert anpassen
-  * geänderten CV-Wert speichern. Es können auch mehrere Werte verändert und gespeichert werden, bevor die Übertragung auf den Knoten erfolgt.+  * geänderten CV-Wert speichern ​(Merken). Es können auch mehrere Werte verändert und gespeichert werden, bevor die Übertragung auf den Knoten erfolgt.
   * geänderte CV-Werte auf den Knoten übertragen   * geänderte CV-Werte auf den Knoten übertragen
  
Zeile 818: Zeile 845:
 Ab dem Wizard-1.9 ist ein direkter Zugriff auf die Debug-Schnittstelle möglich statt hterm zu benutzen. Dazu müssen die Schnittstelle und die Baudrate aus den entsprechenden Comboboxen ausgewählt werden. Ab dem Wizard-1.9 ist ein direkter Zugriff auf die Debug-Schnittstelle möglich statt hterm zu benutzen. Dazu müssen die Schnittstelle und die Baudrate aus den entsprechenden Comboboxen ausgewählt werden.
  
-:!: Wenn der Wizard auf einem ARM-Prozessor läuft, muss in den **Einstellungen** der //Serielle Port Treiber// auf **RXTX** gestellt werden! ​ 
  
 {{ :​wizard:​wizard-debug-interface.png |}} {{ :​wizard:​wizard-debug-interface.png |}}
Zeile 826: Zeile 852:
 Für die Übertragung einer Firmware-Datei muss '​f'​ oder '​e'​ in das Testfeld '​Senden'​ eingegeben und gesendet werden. Anschliessend muss die Datei ausgewählt und dann durch Klick auf '​Senden'​ gesendet werden. Für die Übertragung einer Firmware-Datei muss '​f'​ oder '​e'​ in das Testfeld '​Senden'​ eingegeben und gesendet werden. Anschliessend muss die Datei ausgewählt und dann durch Klick auf '​Senden'​ gesendet werden.
  
-==== Update vom GBM16T mit dem BiDiB-Wizard ​(Entwicklungsstand vom Wiki) ====+==== Update vom GBM16T mit dem BiDiB-Wizard ====
  
 :!: Für das Update des GBM16T wird ein FTDI-Kabel (3.3V) benötigt, welches auf den Debug-Port gesteckt werden muss. Siehe auch [[update_ftdi|Logging über FTDI-Kabel]]. :!: Für das Update des GBM16T wird ein FTDI-Kabel (3.3V) benötigt, welches auf den Debug-Port gesteckt werden muss. Siehe auch [[update_ftdi|Logging über FTDI-Kabel]].
Zeile 854: Zeile 880:
 8-o Falls der GBM16T nach dem Update einen Nightrider auf POW, BiDiB und den anderen 2 LEDs hat, kann normalerweise der Ident-Taster gedrückt werden um den Kalibrierungsmodus zu verlassen. Dieser Hinweis per Nightrider deutet darauf hin, dass der GBM16T in den Kalibrierungsmodus gewechselt hat. 8-o Falls der GBM16T nach dem Update einen Nightrider auf POW, BiDiB und den anderen 2 LEDs hat, kann normalerweise der Ident-Taster gedrückt werden um den Kalibrierungsmodus zu verlassen. Dieser Hinweis per Nightrider deutet darauf hin, dass der GBM16T in den Kalibrierungsmodus gewechselt hat.
  
-==== Update vom GBMboost Master mit dem BiDiB-Wizard ​(Entwicklungsstand vom Wiki) ====+==== Update vom GBMboost Master mit dem BiDiB-Wizard ====
  
  
wizard.1579074728.txt.gz · Zuletzt geändert: 2020/01/15 08:52 von akuhtz