Benutzer-Werkzeuge

Webseiten-Werkzeuge


wizard

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
wizard [2019/05/29 19:09]
akuhtz [Entwicklungsstand] Fix OneDMXSimulator
wizard [2019/12/08 17:14] (aktuell)
akuhtz [Entwicklungsstand] Build 3819
Zeile 25: Zeile 25:
 ===== Download ===== ===== Download =====
  
-**veröffentlichte ​Version:​**  ​+**Aktuelle Release-Version:​**  ​
  
-Die aktuelle Version ist der **Wizard-1.11.1** vom 22.12.2018.+Die aktuelle Version ist der **Wizard-1.12.2** vom 05.10.2019.
  
-Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.11.1.jar+Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12.2.jar 
 + 
 +:!: Der Wizard 1.12 verwendet standardmässig ein anderes Format für den Knoten-Export und Import. Man kann das in den Einstellungen > Experimentelle Eigenschaften > Java-Serialisierung für Knotenexport verwenden auf das alte Format umschalten. Anschliessend den Wizard neu starten. 
 + 
 +Bitte neue Knoten-Export nur noch mit dem neuen Format (*.nodex) erstellen! Die Unterstützung für das alte Format wird in einem nächsten Release komplett entfernt.
  
-**Entwicklungsstand:​** 
  
 :!: Im Wizard-1.9 wurde das **Datenformat der Bezeichnungen für Ports, Makros und Accessories geändert**! Aus diesem Grund werden die alten Bezeichnungen beim 1. Zugriff mit einer 1.9-er Version automatisch in das neue Format migriert. ​ :!: Im Wizard-1.9 wurde das **Datenformat der Bezeichnungen für Ports, Makros und Accessories geändert**! Aus diesem Grund werden die alten Bezeichnungen beim 1. Zugriff mit einer 1.9-er Version automatisch in das neue Format migriert. ​
Zeile 42: Zeile 45:
 Wichtig ist die Datei mit der Endung **.labels** zu löschen und nicht die gleich lautende Datei mit dem Namen LightPortLabels aber ohne Extension. ​ Wichtig ist die Datei mit der Endung **.labels** zu löschen und nicht die gleich lautende Datei mit dem Namen LightPortLabels aber ohne Extension. ​
 In diesem Fall sind alle bisher geänderten Bezeichnungen mit dem Wizard-1.9 verloren! Falls Bedarf besteht beide Bezeichnungen weiterhin zu behalten, bitte bei mir (andreas.kuhtz@gmail.com) melden bevor die Dateien gelöscht werden. In diesem Fall sind alle bisher geänderten Bezeichnungen mit dem Wizard-1.9 verloren! Falls Bedarf besteht beide Bezeichnungen weiterhin zu behalten, bitte bei mir (andreas.kuhtz@gmail.com) melden bevor die Dateien gelöscht werden.
- 
-:!: Ab Build 2085 wurde der XML-Namespace für die CV-Definitionen von ''​http://​www.bidib.org/​jbidibc/​vendorcv''​ auf ''​http://​www.bidib.org/​schema/​vendorcv''​ geändert. Für Anwender die keine angepassten CV-Definitionen verwenden ist diese Änderung nicht sichtbar. Diejenigen Anwender welche angepasste CV-Definitionen benutzen müssen den  
-Namespace in den BiDiBCV-13-*.xml anpassen. 
  
 :!: Ab Build 2320 wurde das Format für das lokale Speichern der Bezeichnungen (Labels) angepasst. Beim ersten Start erfolgt automatisch eine Migration in das neue Format. Die Dateien des neuen Format liegen unter //​.bidib/​labels//​ und haben das Namensformat //<​Knoten-UID>​.xml//​. :!: Ab Build 2320 wurde das Format für das lokale Speichern der Bezeichnungen (Labels) angepasst. Beim ersten Start erfolgt automatisch eine Migration in das neue Format. Die Dateien des neuen Format liegen unter //​.bidib/​labels//​ und haben das Namensformat //<​Knoten-UID>​.xml//​.
Zeile 52: Zeile 52:
 {{ :​wizard:​wizard-migration-dialog.png |}} {{ :​wizard:​wizard-migration-dialog.png |}}
  
-:!: Erzeugen der Dokumentation (ab Build 2322) ist noch experimentell und nicht vollständig! 
  
 ===== Entwicklungsstand ===== ===== Entwicklungsstand =====
Zeile 58: Zeile 57:
 ** Download Entwicklungsstand ** ** Download Entwicklungsstand **
  
-Der aktuelle Entwicklungsstand (Update: ​29.05.2019, Build 3585, master) vom //​BiDiB-Wizard-1.11// kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.11-20190529.164655-160.jar]]+Der aktuelle Entwicklungsstand (Update: ​08.12.2019, Build 3819, master) vom //BiDiB-Wizard-1.12//​ kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12-20191208.154420-150.jar]]
  
   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.
Zeile 66: Zeile 65:
  
 ===== Installation ===== ===== Installation =====
-Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //​Java ​7-Runtime// (oder neuer) installiert ist. +Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //​Java ​8-Runtime// (oder neuer) installiert ist. 
  
 Sollte die Verknüpfung für Jar-Files durch ein anderes Tool verändert worden sein (z.B. 7-zip), hilft folgendes Kommando auf dem Command-Prompt:​ Sollte die Verknüpfung für Jar-Files durch ein anderes Tool verändert worden sein (z.B. 7-zip), hilft folgendes Kommando auf dem Command-Prompt:​
Zeile 114: Zeile 113:
 ===== Versionsübersicht ===== ===== Versionsübersicht =====
  
-==== Version 1.11 ====+==== Version 1.12 ====
 Aktuelle Version Aktuelle Version
 +  * Unterstützung für ReadyLine-Baugruppen
 +  * Neues Dateiformat für Import/​Export der Knoten
 +
 +==== Version 1.11 ====
   * Unterstützung für OneControl 3.x   * Unterstützung für OneControl 3.x
  
Zeile 200: Zeile 203:
 ==== Logdateien sammeln ==== ==== Logdateien sammeln ====
  
-Mit dem nachfolgenden ​Dialog ​(Menü **//Hilfe > Logdateien sammeln//**kann das Ziel festgelegt werden, an welchen die Logdateien (BiDiBWizard.log und BiDiBWizard-RXTX.log) kopiert werden:+Der Dialog ​zum Sammeln der Logdateien wird über das Menü **//Hilfe > Logdateien sammeln//​** ​geöffnet.  
 + 
 +{{ :​wizard:​wizard-menu-help-collect-logfiles.png |}} 
 + 
 +Mit dem nachfolgenden Dialog ​kann das Ziel festgelegt werden, an welchen die Logdateien (BiDiBWizard.log und BiDiBWizard-RXTX.log) kopiert werden:
  
 {{ :​wizard:​bidib-wizard-logfiles-saveunder-linux.png |}} {{ :​wizard:​bidib-wizard-logfiles-saveunder-linux.png |}}
Zeile 742: Zeile 749:
    
 {{ : wizard:​Wizard-export-node.png }} {{ : wizard:​Wizard-export-node.png }}
 +
 +
 +:!: Der Wizard 1.12 verwendet standardmässig ein anderes Format für den Knoten-Export und Import. Man kann das in den Einstellungen > Experimentelle Eigenschaften > Java-Serialisierung für Knotenexport verwenden auf das alte Format umschalten. Anschliessend den Wizard neu starten.
  
 ===== Import Knoten ===== ===== Import Knoten =====
Zeile 824: Zeile 834:
  
 ==== Update vom GBMboost Master mit dem BiDiB-Wizard (Entwicklungsstand vom Wiki) ==== ==== Update vom GBMboost Master mit dem BiDiB-Wizard (Entwicklungsstand vom Wiki) ====
-Tools > Entwickler-Tools > Debug Interface 
  
-  ​* **Jumper** **J54 Position J3** setzen!+ 
 +{{:​wizard:​firmwareupdate:​gbmboost-jumper-bootloader.png?​400|}} 
 + 
 +  ​* **Jumper** **J54 Position J3** setzen! ​(siehe markierter Jumper im Bild oben)
   * Während dem Einschalten den **Ident-Schalter gedrückt** halten.\\ **Achtung**:​ Anstecken des USB-Kabel startet den GBMboost schon ...   * Während dem Einschalten den **Ident-Schalter gedrückt** halten.\\ **Achtung**:​ Anstecken des USB-Kabel startet den GBMboost schon ...
 +  * Nur die LED **PW** leuchtet ...
 +
 +{{:​wizard:​firmwareupdate:​gbmboost-run-in-bootloader.png?​400|}}
 +
 +  * Wizard starten und über Tools > Entwickler-Tools > Debug Interface das Debug Interface öffnen.
   * Mit Baudrate **19200** verbinden und im Textfeld Senden das **?** eingeben > **Senden** (geht auch mit Enter).   * Mit Baudrate **19200** verbinden und im Textfeld Senden das **?** eingeben > **Senden** (geht auch mit Enter).
   * Ausgabe im Logfenster: **GBMboost-Bootloader V0.02.01** zeigt an, dass der Bootloader aktiv ist.   * Ausgabe im Logfenster: **GBMboost-Bootloader V0.02.01** zeigt an, dass der Bootloader aktiv ist.
Zeile 840: Zeile 857:
  
 {{ :​wizard:​2016-03-26_12-57-45.png |}} {{ :​wizard:​2016-03-26_12-57-45.png |}}
 +
 +==== Update vom GBMboost Master mit hterm ====
 +
 +Die Vorbereitung des GBMboost Master sind wie im vorherigen Abschnitt.
 +
 +  * Hterm starten und nach Auswahl des Port und der Baudrate 19200 mit Connect verbinden.
 +  * Nach der Eingabe des '?'​ und Enter zum Senden antwortet der Bootloader mit dem Text "​GBMboost-Bootloader"​.
 +
 +
 +{{:​wizard:​firmwareupdate:​hterm-bootloader-gbmboost.png?​|}}
 +
wizard.1559149756.txt.gz · Zuletzt geändert: 2019/05/29 19:09 von akuhtz