Benutzer-Werkzeuge

Webseiten-Werkzeuge


wizard

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
wizard [2019/05/14 10:45]
akuhtz [Entwicklungsstand] Fix GBM16TS Melder Kehrschleife
wizard [2020/05/27 11:02] (aktuell)
akuhtz [Download] Wizard-1.12.9
Zeile 25: Zeile 25:
 ===== Download ===== ===== Download =====
  
-**veröffentlichte ​Version:​**  ​+**Aktuelle Release-Version:​**  ​
  
-Die aktuelle Version ist der **Wizard-1.11.1** vom 22.12.2018.+Die aktuelle Version ist der **Wizard-1.12.9** vom 26.05.2020.
  
-Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.11.1.jar+Der BiDiB-Wizard kann hier heruntergeladen werden: http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12.9.jar 
 + 
 +<WRAP center round info 80%> 
 +Der BiDiB-Wizard bringt Unterstützung für mehrere //Serielle Port Treiber// mit. Je nach Betriebssytem kann der eine oder andere Treiber Vorteile haben. Diese //Seriellen Port Treiber// benötigen alle einen korrekt installierten nativen Treiber (z.B. FTDI).  
 + 
 +Alle Treiber die zur Auswahl stehen werden komplett mitgeliefert,​ d.h. es muss keine separate Installation erfolgen.  
 + 
 +Unter **Windows 10 64-bit muss eine 64-bit JVM installiert** und verwendet werden.  
 + 
 +:!: Falls keine COM-Ports angezeigt werden oder das Fenster mit dem COM-Port nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ installiert werden (Google nach: "​vcredist_x64.exe 2013" oder https://​support.microsoft.com/​de-de/​help/​4032938/​update-for-visual-c-2013-redistributable-package). 
 + 
 +Die **deutsche Version für Windows 10 64-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x64-deu-2013.exe|auch von hier]] heruntergeladen werden.  
 + 
 +Die **deutsche Version für Windows 10 32-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x86-deu-2013.exe|auch von hier]] heruntergeladen werden. 
 + 
 + 
 +Siehe auch [[wizard#​usb_hot-plug|USB hotplug]]. 
 +</​WRAP>​ 
 + 
 +:!: Der Wizard 1.12 verwendet standardmässig ein anderes Format für den Knoten-Export und Import. Man kann das in den Einstellungen > Experimentelle Eigenschaften > Java-Serialisierung für Knotenexport verwenden auf das alte Format umschalten. Anschliessend den Wizard neu starten. 
 + 
 +Bitte neue Knoten-Export nur noch mit dem neuen Format (*.nodex) erstellen! Die Unterstützung für das alte Format wird in einem nächsten Release komplett entfernt.
  
-**Entwicklungsstand:​** 
  
 :!: Im Wizard-1.9 wurde das **Datenformat der Bezeichnungen für Ports, Makros und Accessories geändert**! Aus diesem Grund werden die alten Bezeichnungen beim 1. Zugriff mit einer 1.9-er Version automatisch in das neue Format migriert. ​ :!: Im Wizard-1.9 wurde das **Datenformat der Bezeichnungen für Ports, Makros und Accessories geändert**! Aus diesem Grund werden die alten Bezeichnungen beim 1. Zugriff mit einer 1.9-er Version automatisch in das neue Format migriert. ​
Zeile 42: Zeile 62:
 Wichtig ist die Datei mit der Endung **.labels** zu löschen und nicht die gleich lautende Datei mit dem Namen LightPortLabels aber ohne Extension. ​ Wichtig ist die Datei mit der Endung **.labels** zu löschen und nicht die gleich lautende Datei mit dem Namen LightPortLabels aber ohne Extension. ​
 In diesem Fall sind alle bisher geänderten Bezeichnungen mit dem Wizard-1.9 verloren! Falls Bedarf besteht beide Bezeichnungen weiterhin zu behalten, bitte bei mir (andreas.kuhtz@gmail.com) melden bevor die Dateien gelöscht werden. In diesem Fall sind alle bisher geänderten Bezeichnungen mit dem Wizard-1.9 verloren! Falls Bedarf besteht beide Bezeichnungen weiterhin zu behalten, bitte bei mir (andreas.kuhtz@gmail.com) melden bevor die Dateien gelöscht werden.
- 
-:!: Ab Build 2085 wurde der XML-Namespace für die CV-Definitionen von ''​http://​www.bidib.org/​jbidibc/​vendorcv''​ auf ''​http://​www.bidib.org/​schema/​vendorcv''​ geändert. Für Anwender die keine angepassten CV-Definitionen verwenden ist diese Änderung nicht sichtbar. Diejenigen Anwender welche angepasste CV-Definitionen benutzen müssen den  
-Namespace in den BiDiBCV-13-*.xml anpassen. 
  
 :!: Ab Build 2320 wurde das Format für das lokale Speichern der Bezeichnungen (Labels) angepasst. Beim ersten Start erfolgt automatisch eine Migration in das neue Format. Die Dateien des neuen Format liegen unter //​.bidib/​labels//​ und haben das Namensformat //<​Knoten-UID>​.xml//​. :!: Ab Build 2320 wurde das Format für das lokale Speichern der Bezeichnungen (Labels) angepasst. Beim ersten Start erfolgt automatisch eine Migration in das neue Format. Die Dateien des neuen Format liegen unter //​.bidib/​labels//​ und haben das Namensformat //<​Knoten-UID>​.xml//​.
Zeile 52: Zeile 69:
 {{ :​wizard:​wizard-migration-dialog.png |}} {{ :​wizard:​wizard-migration-dialog.png |}}
  
-:!: Erzeugen der Dokumentation (ab Build 2322) ist noch experimentell und nicht vollständig! 
  
 ===== Entwicklungsstand ===== ===== Entwicklungsstand =====
Zeile 58: Zeile 74:
 ** Download Entwicklungsstand ** ** Download Entwicklungsstand **
  
-Der aktuelle Entwicklungsstand (Update: ​13.05.2019, Build 3582, master) vom //​BiDiB-Wizard-1.11// kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.11-20190513.125723-157.jar]]+Der aktuelle Entwicklungsstand (Update: ​25.05.2020, Build 4088, master) vom //BiDiB-Wizard-1.12//​ kann hier heruntergeladen werden [[http://​www.fichtelbahn.de/​files/​wizard-fw/​bidibwizard-installer-1.12-20200525.191101-438.jar]]
  
   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.   * Ab Build 3180: Lauffähig unter Java 9 und Java 10.
Zeile 64: Zeile 80:
  
 ---- ----
- 
 ===== Installation ===== ===== Installation =====
-Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //​Java ​7-Runtime// (oder neuer) installiert ist. +Die Installation des BiDiB-Wizard erfolgt über ein "​executable-Jar"​ welches im Normalfall unter Windows per Doppelklick gestartet werden kann, wenn eine //​Java ​8-Runtime// (oder neuer) installiert ist. 
  
 Sollte die Verknüpfung für Jar-Files durch ein anderes Tool verändert worden sein (z.B. 7-zip), hilft folgendes Kommando auf dem Command-Prompt:​ Sollte die Verknüpfung für Jar-Files durch ein anderes Tool verändert worden sein (z.B. 7-zip), hilft folgendes Kommando auf dem Command-Prompt:​
Zeile 83: Zeile 98:
 Bevor erstmalig eine Verbindung zum Master erstellt werden kann, muss der verwendete Port über **Bearbeiten > Einstellungen** ausgewählt werden (USB-Verbindung zum GBMboost muss eingesteckt sein). Anschließend kann die Verbindung über **Datei > Verbinden** oder über den Connect-Button hergestellt werden. Bevor erstmalig eine Verbindung zum Master erstellt werden kann, muss der verwendete Port über **Bearbeiten > Einstellungen** ausgewählt werden (USB-Verbindung zum GBMboost muss eingesteckt sein). Anschließend kann die Verbindung über **Datei > Verbinden** oder über den Connect-Button hergestellt werden.
 Sobald die Verbindung zum Master steht, werden alle Knoten gelesen und in einer Baumstruktur dargestellt. Sobald die Verbindung zum Master steht, werden alle Knoten gelesen und in einer Baumstruktur dargestellt.
 +
 +==== Sprache ändern ====
 +
 +Die Sprache des Wizard kann wie folgt geändert werden:
 +  * Unter Windows: Im Installations-Verzeichnis vom Wizard gibt es die Datei BiDiB-Wizard.l4j.ini. ​
 +  * Unter Linux: Es gibt ein bash-Script welches den Wizard startet.
 +\\  ​
 +Der folgende Parameter bestimmt die Sprache:
 +''​
 +-Duser.language=de
 +''​
 +
 +
 +Wenn man für ''​-Duser.language=en''​ angibt wird der Wizard in Englisch gestartet.
 +
  
 ==== Installation auf Raspi 3 ==== ==== Installation auf Raspi 3 ====
Zeile 114: Zeile 144:
 ===== Versionsübersicht ===== ===== Versionsübersicht =====
  
-==== Version 1.11 ====+==== Version 1.12 ====
 Aktuelle Version Aktuelle Version
 +  * Unterstützung für ReadyLine-Baugruppen
 +  * Neues Dateiformat für Import/​Export der Knoten
 +  * Korrektur: Fahren mit 28 Fahrstufen (1.12.7)
 +
 +==== Version 1.11 ====
   * Unterstützung für OneControl 3.x   * Unterstützung für OneControl 3.x
  
Zeile 200: Zeile 235:
 ==== Logdateien sammeln ==== ==== Logdateien sammeln ====
  
-Mit dem nachfolgenden ​Dialog ​(Menü **//Hilfe > Logdateien sammeln//**kann das Ziel festgelegt werden, an welchen die Logdateien (BiDiBWizard.log und BiDiBWizard-RXTX.log) kopiert werden:+Der Dialog ​zum Sammeln der Logdateien wird über das Menü **//Hilfe > Logdateien sammeln//​** ​geöffnet.  
 + 
 +{{ :​wizard:​wizard-menu-help-collect-logfiles.png |}} 
 + 
 +Mit dem nachfolgenden Dialog ​kann das Ziel festgelegt werden, an welchen die Logdateien (BiDiBWizard.log und BiDiBWizard-RXTX.log) kopiert werden:
  
 {{ :​wizard:​bidib-wizard-logfiles-saveunder-linux.png |}} {{ :​wizard:​bidib-wizard-logfiles-saveunder-linux.png |}}
Zeile 259: Zeile 298:
 Ab Build 2507 wird anschliessend automatisch die Verbindung zum Interface aufgebaut. Ab Build 2507 wird anschliessend automatisch die Verbindung zum Interface aufgebaut.
  
-:!: Falls das Fenster nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ (Google nach: "​vcredist_x64.exe ​2017") installiert werden.+:!: Falls das Fenster nicht erscheint müssen vermutlich die "​Visual C++ Redistributable für Visual Studio"​ (Google nach: "​vcredist_x64.exe ​2013" ​oder https://​support.microsoft.com/​de-de/​help/​4032938/​update-for-visual-c-2013-redistributable-package,​ Achtung: Für Windows passende 64-bit oder 32-bit Version downloaden) installiert ​werden. 
 + 
 +Die **deutsche Version für Windows 10 64-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x64-deu-2013.exe|auch von hier]] heruntergeladen werden.  
 + 
 +Die **deutsche Version für Windows 10 32-bit** kann [[http://​www.fichtelbahn.de/​files/​wizard-fw/​vcredist/​vcredist_x86-deu-2013.exe|auch von hier]] heruntergeladen ​werden.
  
 ---- ----
Zeile 311: Zeile 354:
  
 Über das Kontext-Menü kann der Neustart ausgelöst werden. Über das Kontext-Menü kann der Neustart ausgelöst werden.
 +
 +==== Anzeige Knotenname ====
 +
 +Wenn man dem Knoten einen Namen gibt, wird diese Information lokal gespeichert (<​userhome>​\.bidib\labels) sowie auf den Knoten übertragen. Der Speicherplatz auf dem Knoten ist limitiert (i.A. 16-24 Zeichen) während lokal keine Begrenzung besteht. Wird eine Name eingegeben der länger ist als das was auf dem Knoten gespeichert werden kann, dann wird der Teil der zu lang ist im Wizard Knotenbaum blau dargestellt statt schwarz.
 +
 +Falls auf dem Knoten und lokal kein Name gespeichert ist, wird die UniqueID des Knoten im Knotenbaum blau dargestellt.
 ----- -----
  
Zeile 630: Zeile 679:
 In der Spalte Aktion kann bestimmt werden, ob die Meldung gesendet wird, wenn der selektierte Port **zum Zeitpunkt der Abarbeitung dieses Schritt** den Wert = 0 oder Wert = 1 hat.  In der Spalte Aktion kann bestimmt werden, ob die Meldung gesendet wird, wenn der selektierte Port **zum Zeitpunkt der Abarbeitung dieses Schritt** den Wert = 0 oder Wert = 1 hat. 
  
 +==== Flag abfragen ====
  
 +Mit dem Makroschritt ''​Flag abfragen''​ wird die Ausführung eines Makro anhand eines gesetzten oder nicht gesetzten Flag pausiert. D.h. wenn die Bedingung nicht erfüllt ist, wartet das Makro in diesem Schritt solange, bis die Bedingung erfüllt ist.
 +
 +Der Makroschritt ''​Flag abfragen 1''​ pausiert das Makro solange, bis das Flag gesetzt ist.
 +Der Makroschritt ''​Flag abfragen 0''​ pausiert das Makro solange, bis das Flag nicht (mehr) gesetzt ist.
  
 ---- ----
Zeile 742: Zeile 796:
    
 {{ : wizard:​Wizard-export-node.png }} {{ : wizard:​Wizard-export-node.png }}
 +
 +
 +:!: Der Wizard 1.12 verwendet standardmässig ein anderes Format für den Knoten-Export und Import. Man kann das in den Einstellungen > Experimentelle Eigenschaften > Java-Serialisierung für Knotenexport verwenden auf das alte Format umschalten. Anschliessend den Wizard neu starten.
  
 ===== Import Knoten ===== ===== Import Knoten =====
Zeile 787: Zeile 844:
 Ab dem Wizard-1.9 ist ein direkter Zugriff auf die Debug-Schnittstelle möglich statt hterm zu benutzen. Dazu müssen die Schnittstelle und die Baudrate aus den entsprechenden Comboboxen ausgewählt werden. Ab dem Wizard-1.9 ist ein direkter Zugriff auf die Debug-Schnittstelle möglich statt hterm zu benutzen. Dazu müssen die Schnittstelle und die Baudrate aus den entsprechenden Comboboxen ausgewählt werden.
  
-:!: Wenn der Wizard auf einem ARM-Prozessor läuft, muss in den **Einstellungen** der //Serielle Port Treiber// auf **RXTX** gestellt werden! ​ 
  
 {{ :​wizard:​wizard-debug-interface.png |}} {{ :​wizard:​wizard-debug-interface.png |}}
Zeile 795: Zeile 851:
 Für die Übertragung einer Firmware-Datei muss '​f'​ oder '​e'​ in das Testfeld '​Senden'​ eingegeben und gesendet werden. Anschliessend muss die Datei ausgewählt und dann durch Klick auf '​Senden'​ gesendet werden. Für die Übertragung einer Firmware-Datei muss '​f'​ oder '​e'​ in das Testfeld '​Senden'​ eingegeben und gesendet werden. Anschliessend muss die Datei ausgewählt und dann durch Klick auf '​Senden'​ gesendet werden.
  
-==== Update vom GBM16T mit dem BiDiB-Wizard ​(Entwicklungsstand vom Wiki) ====+==== Update vom GBM16T mit dem BiDiB-Wizard ====
  
 :!: Für das Update des GBM16T wird ein FTDI-Kabel (3.3V) benötigt, welches auf den Debug-Port gesteckt werden muss. Siehe auch [[update_ftdi|Logging über FTDI-Kabel]]. :!: Für das Update des GBM16T wird ein FTDI-Kabel (3.3V) benötigt, welches auf den Debug-Port gesteckt werden muss. Siehe auch [[update_ftdi|Logging über FTDI-Kabel]].
Zeile 823: Zeile 879:
 8-o Falls der GBM16T nach dem Update einen Nightrider auf POW, BiDiB und den anderen 2 LEDs hat, kann normalerweise der Ident-Taster gedrückt werden um den Kalibrierungsmodus zu verlassen. Dieser Hinweis per Nightrider deutet darauf hin, dass der GBM16T in den Kalibrierungsmodus gewechselt hat. 8-o Falls der GBM16T nach dem Update einen Nightrider auf POW, BiDiB und den anderen 2 LEDs hat, kann normalerweise der Ident-Taster gedrückt werden um den Kalibrierungsmodus zu verlassen. Dieser Hinweis per Nightrider deutet darauf hin, dass der GBM16T in den Kalibrierungsmodus gewechselt hat.
  
-==== Update vom GBMboost Master mit dem BiDiB-Wizard ​(Entwicklungsstand vom Wiki) ==== +==== Update vom GBMboost Master mit dem BiDiB-Wizard ====
-Tools > Entwickler-Tools > Debug Interface+
  
-  ​* **Jumper** **J54 Position J3** setzen!+ 
 +{{:​wizard:​firmwareupdate:​gbmboost-jumper-bootloader.png?​400|}} 
 + 
 +  ​* **Jumper** **J54 Position J3** setzen! ​(siehe markierter Jumper im Bild oben)
   * Während dem Einschalten den **Ident-Schalter gedrückt** halten.\\ **Achtung**:​ Anstecken des USB-Kabel startet den GBMboost schon ...   * Während dem Einschalten den **Ident-Schalter gedrückt** halten.\\ **Achtung**:​ Anstecken des USB-Kabel startet den GBMboost schon ...
 +  * Nur die LED **PW** leuchtet ...
 +
 +{{:​wizard:​firmwareupdate:​gbmboost-run-in-bootloader.png?​400|}}
 +
 +  * Wizard starten und über Tools > Entwickler-Tools > Debug Interface das Debug Interface öffnen.
   * Mit Baudrate **19200** verbinden und im Textfeld Senden das **?** eingeben > **Senden** (geht auch mit Enter).   * Mit Baudrate **19200** verbinden und im Textfeld Senden das **?** eingeben > **Senden** (geht auch mit Enter).
   * Ausgabe im Logfenster: **GBMboost-Bootloader V0.02.01** zeigt an, dass der Bootloader aktiv ist.   * Ausgabe im Logfenster: **GBMboost-Bootloader V0.02.01** zeigt an, dass der Bootloader aktiv ist.
Zeile 840: Zeile 903:
  
 {{ :​wizard:​2016-03-26_12-57-45.png |}} {{ :​wizard:​2016-03-26_12-57-45.png |}}
 +
 +==== Update vom GBMboost Master mit hterm ====
 +
 +Die Vorbereitung des GBMboost Master sind wie im vorherigen Abschnitt.
 +
 +  * Hterm starten und nach Auswahl des Port und der Baudrate 19200 mit Connect verbinden.
 +  * Nach der Eingabe des '?'​ und Enter zum Senden antwortet der Bootloader mit dem Text "​GBMboost-Bootloader"​.
 +
 +
 +{{:​wizard:​firmwareupdate:​hterm-bootloader-gbmboost.png?​|}}
 +
wizard.1557823525.txt.gz · Zuletzt geändert: 2019/05/14 10:45 von akuhtz